• Rejestracja
vBHELP.pl - polskie wsparcie vBulletin
Strona 1 z 2 12 OstatniOstatni
  1. #1
    kris jest nieaktywny Początkujący
    Dołączył
    lip 2008
    Posty
    2

    Domyślnie polskie znaki w spolszczeniu

    Witam!

    Wgrałem spolszczenie 3.7.2 po instalacji serwisu. w postach mam polskie znaki a w napisach pochodzących ze strony nie.
    ustawienia strony są takie:
    <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-2" />

    a na stronie wychodzą takie kwiatki:
    Lista u?ytkownik?w

    Pozdrawiam

    Kris



  2. #2
    Awatar Ctrl
    Ctrl jest nieaktywny Advanced Member
    Dołączył
    sty 2008
    Przegląda
    $location = $lang['Toruń'];
    Posty
    1 046

    Domyślnie

    spróbuj "ISO-8859-1"
    GG:10038207
    Instalacje, Aktualizacje, Tworzenie Skinów, Przenoszenie, Support,
    Gadu-Gadu jest moim prywatnym komunikatorem.
    Wszelką pomoc realizuję jedynie poprzez forum.(No chyba,że dasz mi zarobić,wtedy pisz.)


  3. #3
    Awatar Max
    Max
    Max jest nieaktywny There's something in the Air ...
    Dołączył
    sty 2008
    Posty
    4 775
    Przydatne posty
    252
    Wpisów
    13

    Domyślnie

    Przejdź do:
    AdminCP -> Języki i Frazy -> Zarządzaj Językiem -> Polski -> [Edytuj Ustawienia]

    W polu 'HTML Character Set' spróbuj ustawić 'ISO-8859-2' lub 'UTF-8'.

    Pozdr.


  4. #4
    Awatar WoG
    WoG
    WoG jest nieaktywny vB Specialist
    Dołączył
    lut 2008
    Posty
    2 812
    Przydatne posty
    297
    Wpisów
    1

    Domyślnie

    kris, ja mając ten problem ustawiłem w config.php kodowanie takie jak mam w bazie czyli

    Kod php:
    // $config['Mysqli']['charset'] = 'utf8'; 
    Zamieniłem na:
    Kod php:
    $config['Mysqli']['charset'] = 'latin1'
    Wgrałem spolszczenie od nowa i działa
    Pamiętaj, że niekoniecznie musi być latin1. Ten wpis zależy od Twojej bazy danych.
    Z poważaniem,
    WoG

    Ty też możesz pomóc spolszczać vBulletin 5: GitHub.com
    "Rozczarowanie spowodowane niską jakością pamięta się długo po przeminięciu radości spowodowanej niską ceną"


  5. #5
    kris jest nieaktywny Początkujący
    Dołączył
    lip 2008
    Posty
    2

    Domyślnie

    dzięki za odpowiedzi.
    Pomogło przekonwertowanie polskiego tłumaczenia do UTF-8, zmiana znacnzika kodowania na UTF-8 i ponowne wgranie.


  6. #6
    Awatar Max
    Max
    Max jest nieaktywny There's something in the Air ...
    Dołączył
    sty 2008
    Posty
    4 775
    Przydatne posty
    252
    Wpisów
    13

    Domyślnie

    Jeśli zainstalowałeś forum w UTF-8 (o czym nie wspomniałeś w pierwszym poście) to oczywiste, że takie kodowanie należało zastosować w tłumaczeniu.


  7. #7
    yacenty jest nieaktywny Początkujący
    Dołączył
    paź 2008
    Posty
    17

    Domyślnie

    chłopaki, pomożcie, na forum mam krzaki w tłumaczeniu ktore sciagnałem z tego forum.

    moje ustawienia bazy to:
    Kod:
    character set client  	utf8
    (Wartość globalna) 	latin1
    character set connection 	utf8
    (Wartość globalna) 	latin1
    character set database 	latin1
    character set filesystem 	binary
    character set results 	utf8
    (Wartość globalna) 	latin1
    character set server 	latin1
    character set system 	utf8
    character sets dir 	/usr/local/mysql/share/mysql/charsets/
    collation connection 	utf8_unicode_ci
    (Wartość globalna) 	latin1_swedish_ci
    collation database 	latin1_swedish_ci
    collation server 	latin1_swedish_ci
    w pliku config.php linijke
    Kod:
    // $config['Mysqli']['charset'] = 'utf8';
    mam jak widac wykomentowana.
    jak ją odkomentuje to łapie 2 warningi i kupa nic nie widac na forum wtedy:
    Kod:
    Warning: array_keys() [function.array-keys]: The first argument should be an array in [path]/includes/functions.php on line 4098
    
    Warning: Invalid argument supplied for foreach() in [path]/includes/functions.php on line 4098
    podpowiedzcie prosze jak to poskładać do kupy aby w końcu mieć forum spolonizowane i bez krzaków,
    z góry wielkie dzieki

    jakby ktos potrzebował: forum stoi tutaj - legnicka.pl/forum


  8. #8
    Awatar Max
    Max
    Max jest nieaktywny There's something in the Air ...
    Dołączył
    sty 2008
    Posty
    4 775
    Przydatne posty
    252
    Wpisów
    13

    Domyślnie

    Zmień kodowanie bazy danych na latin2 i wgraj tłumaczenie na nowo.
    Od następnego razu zakładaj nowy temat na swój problem.


  9. #9
    yacenty jest nieaktywny Początkujący
    Dołączył
    paź 2008
    Posty
    17

    Domyślnie

    ok, nastepnym razem założe, wydawało mi się ze problem jest zblizony dlatego zadałem pytanie tutaj.
    Powiedz mi jak najprosciej zmienic to kodowanie bazy? nie zalezy mi jakos szczegolnie na ogonkach bo nie mamy zbyt duzo postów wiec w ostatecznosci moge je poprawic recznie.
    Co i gdzie wyklikac zeby zmienic kodowanie bazy i ewentualnie w jakich miejscach wprowadzic zmiany po stronie vB?

    z góry dzieks


  10. #10
    Awatar Max
    Max
    Max jest nieaktywny There's something in the Air ...
    Dołączył
    sty 2008
    Posty
    4 775
    Przydatne posty
    252
    Wpisów
    13

    Domyślnie

    Jeśli korzystasz z phpMyAdmin to jest tam opcja zmiany kodowania bazy danych.


Strona 1 z 2 12 OstatniOstatni

Podobne wątki

  1. Polskie znaki, vB 3.8.1 =(
    By Neil in forum Spolszczenia
    Odpowiedzi: 4
    Ostatni post / autor: 01.06.2009, 18:25
  2. Polskie znaki
    By Newbie in forum Instalacja i upgrade
    Odpowiedzi: 2
    Ostatni post / autor: 06.05.2009, 16:37
  3. Polskie znaki
    By Mr.Leon in forum Pytania i problemy
    Odpowiedzi: 11
    Ostatni post / autor: 26.03.2009, 21:13
  4. Polskie znaki
    By seba766 in forum Konwersje
    Odpowiedzi: 5
    Ostatni post / autor: 24.05.2008, 13:54
  5. Polskie znaki
    By seba766 in forum Pytania i problemy
    Odpowiedzi: 13
    Ostatni post / autor: 10.04.2008, 11:38
Chmurka.pl

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67