• Rejestracja
vBHELP.pl - polskie wsparcie vBulletin
  1. #1
    toxicmaster jest nieaktywny Stały bywalec
    Dołączył
    kwi 2011
    Posty
    105
    Przydatne posty
    3

    Domyślnie problem z konwersja z mybb3

    Witam, mam znaki zapytania:/ phpbb3 tebele maja kodowanie utf8_bin a cała baza Latin2_general_ci


    jak przygotować bazę aby nie było znaków zapytania i innych krzaków?
    Ostatnio edytowane przez toxicmaster ; 31.03.2012 o 01:31



  2. #2
    Mateusz K. jest nieaktywny vBHELP.pl Team
    Dołączył
    wrz 2008
    Posty
    1 447
    Przydatne posty
    164

    Domyślnie

    A próbowałeś przekonwertować ? A później już pod skryptem vb w pliku config.php narzucić kodowanie ?

    W pliku config.php

    Zmień linię:
    Kod:
    // $config['Mysqli']['charset'] = 'utf8';
    na:
    Kod:
    $config['Mysqli']['charset'] = 'latin2';
    lub

    Kod:
     $config['Mysqli']['charset'] = 'latin1';
    lub

    Kod:
    $config['Mysqli']['charset'] = 'utf8';


  3. #3
    toxicmaster jest nieaktywny Stały bywalec
    Dołączył
    kwi 2011
    Posty
    105
    Przydatne posty
    3

    Domyślnie

    kombinowałem wszystko... podczas konwersji widze jak konwertuje się już z krzakami ?#$


  4. #4
    Awatar Mateusz
    Mateusz jest nieaktywny vBHELP.pl Team
    Dołączył
    lut 2008
    Przegląda
    Gdańsk
    Posty
    542
    Przydatne posty
    118
    Wpisów
    2

    Domyślnie

    upload\impexImpExConfig.php

    // Advanced Target
    $impexconfig['target']['databasetype'] = 'mysql'; // currently mysql only
    $impexconfig['target']['charset'] = '';
    $impexconfig['target']['persistent'] = false; // (true/false) use mysql_pconnect

    // Advanced Source
    $impexconfig['source']['charset'] = '';
    $impexconfig['source']['persistent'] = false;


  5. #5
    toxicmaster jest nieaktywny Stały bywalec
    Dołączył
    kwi 2011
    Posty
    105
    Przydatne posty
    3

    Domyślnie

    po przekonwertowaniu userów mam błąd:/
    Kod:
    Warning: number_format() expects parameter 1 to be double, string given in [path]/includes/functions.php on line 553
    
    Warning: number_format() expects parameter 1 to be double, string given in [path]/includes/functions.php on line 553
    błąd się sam rozwiązał:/
    i
    Kod:
    Parse error: syntax error, unexpected T_ENCAPSED_AND_WHITESPACE in /home/elitega1/domains/cs-badboys.com.pl/public_html/includes/class_bootstrap.php(429) : eval()'d code on line 323
    BLAD OD WTYCZKI TABS

    ten błąd niszczy mi forum:/
    Ostatnio edytowane przez toxicmaster ; 06.04.2012 o 12:41


Chmurka.pl

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67