• Rejestracja
vBHELP.pl - polskie wsparcie vBulletin
  1. #1
    Awatar g0rn
    g0rn jest nieaktywny Stały bywalec
    Dołączył
    maj 2009
    Posty
    188
    Przydatne posty
    5

    Domyślnie Problem po upgrade

    Po upgrade z wersji 3.8.4 na vB 3.8.5 występuje błąd podczas przenoszenia postów , tematów do innego działu poprzez "Przenieś posty do istniejącego tematu" URL .
    Kod:
    You have not specified a valid URL for the thread that you want to merge. Please check that the URL includes a valid threadid, "t=xxx" or postid, "p=xxx" (where xxx is a number), and is not a redirect.
    Jak naprawić błąd ?



  2. #2
    Awatar Grzegorz
    Grzegorz jest nieaktywny Ja tu tylko sprzątam
    Dołączył
    sty 2008
    Posty
    1 620
    Przydatne posty
    111

    Domyślnie

    Próbowałeś użyć pliku tools.php?
    Potrzebujesz stylu dla swojego forum? Chcesz przenieść styl z vbulletin 3 na vbulletin 4? Pisz PW


  3. #3
    Awatar g0rn
    g0rn jest nieaktywny Stały bywalec
    Dołączył
    maj 2009
    Posty
    188
    Przydatne posty
    5

    Domyślnie

    Jeszcze nie . Jaką mam opcję z tools.php wybrać ?


  4. #4
    Awatar header
    header jest nieaktywny Advanced Member
    Dołączył
    wrz 2008
    Przegląda
    Myszków
    Posty
    661
    Przydatne posty
    5
    Wpisów
    7

    Domyślnie

    Korzystasz z vBseo ?
    Mój Blog

    Oferty w sprawie konfiguracji i pomocy przy vBulletin proszę kierować na PW lub GG.

    Kliknij by napisać PW
    GG : 20650


  5. #5
    Awatar g0rn
    g0rn jest nieaktywny Stały bywalec
    Dołączył
    maj 2009
    Posty
    188
    Przydatne posty
    5

    Domyślnie

    Tak , ale to problem ze strony skryptu vB , gdyż nawet przy wyłączonym vbseo problem występuje.


  6. #6
    Awatar header
    header jest nieaktywny Advanced Member
    Dołączył
    wrz 2008
    Przegląda
    Myszków
    Posty
    661
    Przydatne posty
    5
    Wpisów
    7

    Domyślnie

    Apache czy lighthttp ?
    Pokaż swój htaccess.
    Mój Blog

    Oferty w sprawie konfiguracji i pomocy przy vBulletin proszę kierować na PW lub GG.

    Kliknij by napisać PW
    GG : 20650


  7. #7
    Awatar g0rn
    g0rn jest nieaktywny Stały bywalec
    Dołączył
    maj 2009
    Posty
    188
    Przydatne posty
    5

    Domyślnie

    .htacess standardowy dołączone do vbseo.
    Kod php:
    # Comment the following line (add '#' at the beginning)
    # to disable mod_rewrite functions.
    # Please note: you still need to disable the hack in
    # the vBSEO control panel to stop url rewrites.
    RewriteEngine On

    # Some servers require the Rewritebase directive to be
    # enabled (remove '#' at the beginning to activate)
    # Please note: when enabled, you must include the path
    # to your root vB folder (i.e. RewriteBase /forums/)
    #RewriteBase /

    RewriteCond %{HTTP_HOST} ^www\.(.+)$ [NC]
    RewriteRule ^(.*)$ http://%1/$1 [R=301,L] 

    RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$[L]

    RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron|vbseo_sitemap)
    RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbseo.php [L,QSA]

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond 
    %{REQUEST_FILENAME} !-d
    RewriteCond 
    %{REQUEST_FILENAME} !/(admincp|modcp|clientscript|cpstyles|images)/
    RewriteRule ^(.+)$ vbseo.php [L,QSA

    Serwer na LiteSpeed. Na wersji 3.8.4 nie było problemu , dopiero problem wystąpił po upgrade na vB 3.8.5
    Ostatnio edytowane przez g0rn ; 27.03.2010 o 18:27


  8. #8
    Awatar g0rn
    g0rn jest nieaktywny Stały bywalec
    Dołączył
    maj 2009
    Posty
    188
    Przydatne posty
    5

    Domyślnie

    A jednak problem tkwi w samym .htacess

    Błąd występuje gdy mam przekierowanie z www na bez www

    RewriteCond %{HTTP_HOST} ^www\.(.+)$ [NC]
    RewriteRule ^(.*)$ http://%1/$1 [R=301,L]
    Natomiast przy standardowym przekierowniu jest ok

    RewriteCond %{HTTP_HOST} !^www\.example\.com
    RewriteRule (.*) http://www.example.com/$1 [R=301,L]
    Wcześniej tego błędu nie było na vB 3.8.4 i użyciu pierwszej regułki

    adres strony w opcjach vB ustawiony

    http://www.example.com

    Proszę o sugestię ?


Podobne wątki

  1. problem z upgrade do vB4.0.3
    By meschiash in forum Instalacja i upgrade
    Odpowiedzi: 17
    Ostatni post / autor: 11.04.2010, 10:08
  2. Problem z stylami po upgrade.
    By lukas22 in forum Pytania i problemy
    Odpowiedzi: 0
    Ostatni post / autor: 17.09.2009, 15:00
  3. Upgrade 3.7.2 do 3.7.4
    By S.H.A.D.O.W. in forum Instalacja i upgrade
    Odpowiedzi: 2
    Ostatni post / autor: 03.12.2008, 20:55
  4. Upgrade z 3.5.6 do 3.7.1 - problem
    By estre in forum Instalacja i upgrade
    Odpowiedzi: 10
    Ostatni post / autor: 03.07.2008, 18:28
  5. upgrade do 3.7.2
    By bom in forum Instalacja i upgrade
    Odpowiedzi: 3
    Ostatni post / autor: 26.06.2008, 09:06
Chmurka.pl

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67