• Rejestracja
vBHELP.pl - polskie wsparcie vBulletin
  1. #1
    Awatar falon
    falon jest nieaktywny Advanced Member
    Dołączył
    lip 2008
    Posty
    911
    Przydatne posty
    3

    Domyślnie przenosiny i znaki zapytania w bazie zamiast polskich liter

    było mnóstwo o krzakach ale tu trochę inaczej.

    A mianowicie przenoszę forum na vps'a i baza jest niby wgrana poprawnie. Ponieważ w bazie na hoście jak i w bazie na vps'ie sa polskie znaki w tabelach i to samo kodowanie.
    Admin firmy hostingującej twierdzi że baza jest wgrana poprawnie skoro widze polskie znaki poprawnie w tabelach tu i tu.
    Jak z tym teraz walczyć skoro jest poprawnie a mam znaki zapytania zamiast polskich znaków?



  2. #2
    Seba jest nieaktywny Advanced Member
    Dołączył
    lut 2009
    Posty
    1 059
    Przydatne posty
    44

    Domyślnie

    Pogubiłeś kolego kodowania po drodze.

    Kodowanie źródłowej bazy, kodowanie bazy zrzucanej (a zarazem pliku), kodowanie podczas importu, kodowanie nowej bazy danych. Wszystko musi być takie same.

    Ew. baw się z set names.
    Profesjonalne modyfikacje vBulletin oraz style - gg 1981480 badz PW


  3. #3
    Awatar falon
    falon jest nieaktywny Advanced Member
    Dołączył
    lip 2008
    Posty
    911
    Przydatne posty
    3

    Domyślnie

    a czy ja wyraźnie nie napisałem że jest takie samo ?


    edit: dla potomnych!!!
    Jeśli jesteś pewny, że baza wgrana poprawnie, sa te same kodowania i znaki polskie możesz czytać w tabeli to wystarczy (przynajmniej mnie wystarczyło) w pliku config.php zrobić małą zmianę:

    Linię prawie na samym dole / $config['Mysqli']['charset'] = 'utf8'; uruchomić poprzez wywalenie na przodzie "//" i wpisac odpowiedznie kodowanie, np:

    $config['Mysqli']['charset'] = 'latin2';


    nigdy tu na forum o tym nie było, a zrobił to uprzejmy admin z serwerowni dzięki admin
    Ostatnio edytowane przez falon ; 06.11.2009 o 18:49


  4. #4
    Seba jest nieaktywny Advanced Member
    Dołączył
    lut 2009
    Posty
    1 059
    Przydatne posty
    44

    Domyślnie

    o_O

    Może dziwnie zabrzmi, ale ciekawe że przenoszenie forum nie zaczynasz od ustalenia nowego kodowania bazy danych w configu. Gz.
    Profesjonalne modyfikacje vBulletin oraz style - gg 1981480 badz PW


  5. #5
    Awatar falon
    falon jest nieaktywny Advanced Member
    Dołączył
    lip 2008
    Posty
    911
    Przydatne posty
    3

    Domyślnie

    Może dziwnie zabrzmi ale nigdy nie spotkałem się tu na forum o rozmowach o ustawianiu kodowania poprzez config.php. Nigdy nie ruszałem tego ustawienia. Zawsze było zdezaktywowane poprzez // na przodzie linii i wszystko działało. Na nowym serwerze widocznie wymagało uaktywnienia opcji.


  6. #6
    Awatar Max
    Max
    Max jest nieaktywny There's something in the Air ...
    Dołączył
    sty 2008
    Posty
    4 775
    Przydatne posty
    252
    Wpisów
    13

    Domyślnie

    nigdy tu na forum o tym nie było, a zrobił to uprzejmy admin z serwerowni
    Było, niejednokrotnie w temacie o przenoszeniu forum.


Podobne wątki

  1. Facebook i problem polskich liter
    By michal in forum Pytania i problemy
    Odpowiedzi: 1
    Ostatni post / autor: 28.11.2010, 18:19
  2. [?][SMF] Zamiast polskich znaków.
    By Polm in forum Konwersje
    Odpowiedzi: 4
    Ostatni post / autor: 09.02.2010, 12:45
  3. brak polskich liter
    By Tien in forum Pytania i problemy
    Odpowiedzi: 12
    Ostatni post / autor: 26.11.2009, 22:40
  4. [Zlecę] Zrobienie Polskich Znaków Zamiast Znaków Zapytania
    By ziomix28 in forum Giełda
    Odpowiedzi: 9
    Ostatni post / autor: 16.06.2009, 19:47
  5. Odpowiedzi: 22
    Ostatni post / autor: 08.12.2008, 19:42
Chmurka.pl

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67