• Rejestracja
vBHELP.pl - polskie wsparcie vBulletin
  1. #1
    kimer jest nieaktywny Początkujący
    Dołączył
    paź 2009
    Posty
    3

    Domyślnie problem z kodowaniem

    Witam,

    posiadam forum vbulletina (wersja 4.0) i spolszczenie z vbhelp i problem z kodowaniem. Forum pierwotnie zainstalowane zostało w kodowaniu iso-8859-2, natomiast baza danych była ustawiona na utf-8. Po zainstalowaniu spolszczenia wszystko było ok. Forum działało tak ok. miesiaca, ale później zmuszony zostałem do zmiany kodowania na utf-8 (integracja z innym serwisem). Zrobiłem więc dump bazy danych, przekonwertowałem go na utf-8 i wrzuciłem do nowej bazy. Zmieniłem w configu forum na nowa bazę, a w tej bazie w tabeli language dla polskiego ustawiłem utf-8. Niestety na stronie polskie znaki nie sa wyświetlane poprawnie, pomimo tego, że przegladajac je w bazie wszystko wyglada dobrze. Wydaje mi sie, że problem ten spowodowany jest połaczeniem z baza danych - chciałem zmienić domyślne kodowanie w plikach vbulletina na utf-8 jednak i to nie pomogło. Byłbym bardzo wdzięczny za pomoc lub jakakolwiek wskazówkę co może być przyczyna, lub gdzie szukać odpowiedzi.

    Pozdrawiam



  2. #2
    Awatar Max
    Max
    Max jest nieaktywny There's something in the Air ...
    Dołączył
    sty 2008
    Posty
    4 775
    Przydatne posty
    252
    Wpisów
    13

    Domyślnie

    Problem występuje tylko przy frazach stałych, z pliku językowego czy w treści postów również?


  3. #3
    kimer jest nieaktywny Początkujący
    Dołączył
    paź 2009
    Posty
    3

    Domyślnie

    problem występuje przy treściach tłumaczonych z pliku oraz z postów


  4. #4
    Awatar Max
    Max
    Max jest nieaktywny There's something in the Air ...
    Dołączył
    sty 2008
    Posty
    4 775
    Przydatne posty
    252
    Wpisów
    13

    Domyślnie

    Wklej tutaj fragment jakiegoś postu zawierającego polskie znaki (skopiuj bezpośrednio z bazy danych).


  5. #5
    kimer jest nieaktywny Początkujący
    Dołączył
    paź 2009
    Posty
    3

    Domyślnie

    Przykładowy post z bazy danych :
    "Obejmowali po 1 grosz
    Atlantis ma 3,5 mln akcji
    szybko licząc przy cenie 3,2zł za akcje Atlantis zarabia ok 80 gr na akcje( ok 13 mln akcji Atlantisu)- trzeba pamiętać że to wirtualne pieniądze
    Ale może jakaś pompka będzie...."

    I to samo wyswietlane na stronie:
    "
    [ATLANTIS]: dzi? debiut ATLANTIS Energy

    Obejmowali po 1 grosz
    Atlantis ma 3,5 mln akcji
    szybko licz?c przy cenie 3,2z? za akcje Atlantis zarabia ok 80 gr na akcje( ok 13 mln akcji Atlantisu)- trzeba pami?ta? ?e to wirtualne pieni?dze
    Ale mo?e jaka? pompka b?dzie.... "


  6. #6
    Awatar Max
    Max
    Max jest nieaktywny There's something in the Air ...
    Dołączył
    sty 2008
    Posty
    4 775
    Przydatne posty
    252
    Wpisów
    13

    Domyślnie

    W pliku config.php, po zdjęciu komentarza z linijki odpowiadającej za kodowanie, zmień kodowanie kolejno na utf8, latin1, latin2 - i opisz efekty po każdej ze zmian.


Podobne wątki

  1. Problem z kodowaniem na forum?
    By Slateer in forum Pytania i problemy
    Odpowiedzi: 11
    Ostatni post / autor: 11.11.2010, 19:40
  2. ramka [problm z kodowaniem]
    By MaXFireN in forum Pytania i problemy
    Odpowiedzi: 0
    Ostatni post / autor: 15.03.2010, 23:51
  3. Problem z kodowaniem bazy i działaniem funkcji ajax
    By judge in forum Pytania i problemy
    Odpowiedzi: 3
    Ostatni post / autor: 18.02.2010, 13:12
  4. Problem z kodowaniem po przeniesieniu bazy
    By mccn in forum Pytania i problemy
    Odpowiedzi: 5
    Ostatni post / autor: 09.07.2008, 10:47
  5. vBridge - Problem z kodowaniem
    By ZLoMik in forum Pytania i problemy
    Odpowiedzi: 5
    Ostatni post / autor: 15.03.2008, 13:52
Chmurka.pl

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67