• Rejestracja
vBHELP.pl - polskie wsparcie vBulletin
  1. #1
    Awatar Trescom
    Trescom jest nieaktywny Początkujący
    Dołączył
    wrz 2008
    Posty
    11

    Domyślnie Problem z BBcode

    Witam serdecznie jako nowy użyszkodnik Waszego Forum.

    Przejdę może od razu do problemu.

    Na moim Forum (vBulletin 3.7.3) od dłuższego czasu występuje problem z funkcjonowaniem bbcode.
    Mianowicie raz działa, a raz nie.

    Nie jestem pewien, ale sytuacja zaczęła się chyba dziać od momentu przeniesienia Forum z zagranicznego serwera na polski.

    Problem z bbcode tyczy się zarówno postów jak i sygnatur.

    Przykład... wpisując:

    [ b]jakiś tekst[/b] <--- pogrubia się, po odświeżeniu widoku zamienia pogrubiony tekst na tekst z widocznymi tagami [b ][/b]

    [ url=http://www.google.pl]google[/url] <--- jako odnośnik powinien pokazać napis "google", a za chwilę pokazuje tekst razem z tagami (w przypadku linków również raz działają a raz nie)
    I tak jest z większością tagów.

    W Panelu Administracyjnym wszystkie opcje dla BBcode są ustawione poprawnie.

    Prosiłbym o pomoc w tej kwestii. Dodaję, że jeśli napiszę posta bbcode działa poprawnie. Odświeżę widok, przestaje działać. Za jakiś czas znowu odświeżę i znów działa... a za chwilę nie. I tak w koło Macieju :/
    Ostatnio edytowane przez Trescom ; 25.09.2008 o 18:47



  2. #2
    Awatar Max
    Max
    Max jest nieaktywny There's something in the Air ...
    Dołączył
    sty 2008
    Posty
    4 775
    Przydatne posty
    252
    Wpisów
    13

    Domyślnie

    Witaj!
    Jeśli chcesz uzyskać pomoc zapoznaj się proszę z tym tematem:
    http://vbhelp.pl/oga-oszenia-f4/uwag...icy-t1622.html

    Pozdr.
    MK


  3. #3
    Awatar Trescom
    Trescom jest nieaktywny Początkujący
    Dołączył
    wrz 2008
    Posty
    11

    Domyślnie

    Przepraszam, nie zwróciłem uwagi... poprawiłem.


  4. #4
    Awatar Trescom
    Trescom jest nieaktywny Początkujący
    Dołączył
    wrz 2008
    Posty
    11

    Domyślnie

    Rozumiem, że nikt nie jest mi w stanie pomóc :/


  5. #5
    Awatar Max
    Max
    Max jest nieaktywny There's something in the Air ...
    Dołączył
    sty 2008
    Posty
    4 775
    Przydatne posty
    252
    Wpisów
    13

    Domyślnie

    Przy próbie wejścia na Twoje forum otrzymuję...
    Database error
    The database has encountered a problem.


  6. #6
    Awatar Trescom
    Trescom jest nieaktywny Początkujący
    Dołączył
    wrz 2008
    Posty
    11

    Domyślnie

    W tej chwili tak. Nie zdążyliśmy pozmieniać ustawień serwera i były Administrator pokazał naturę dziecka. Chyba nie muszę dokańczać.


  7. #7
    Awatar Trescom
    Trescom jest nieaktywny Początkujący
    Dołączył
    wrz 2008
    Posty
    11

    Domyślnie

    Problem z dostępem do bazy danych zażegnany.

    Nawiązując do bbcode, zauważyłem, że jeśli w bazie danych (na przykład w tabeli "word") nie występuje poprawnie zapisane POLSKIE słowo, to bbcode nie chce działać. W przypadku wyrazów pisanych BEZ OGONKÓW bbcode działał wyśmienicie.
    Gdy nasze Forum powstało (kilka lat temu), znajdowało się na zagranicznym serwerze, na którym domyślnym kodowaniem znaków było latin1. Po przeniesieniu nie tak dawno Forum na polski serwer, okazało się, że kodowaniem na nowym serwerze jest utf-8.
    W bazie danych zamiast polskich znaków - same krzaki. Postanowiłem utworzyć nową bazę danych w obecnym kodowaniu (czyli utf-8). Odtworzyłem wszystkie dane pozbywając się krzaków (niestety Gżegżółka XP okazała się tutaj fiaskiem i robiłem to ręcznie). Po imporcie bazy danych (w utf-8) baza danych prezentuje się idealnie. Ale teraz pokazał się problem w postaci wszystkim znanej........ krzaki. Bez względu na to jakie ustawię kodowanie w samym skrypcie vb pokazują się znane nam wszystkim znaki zapytania, zamiast naszych "ogonków". Bardzo proszę o pomoc, bo już mi ręce opadają.

    Na razie Forum zamknąłem, żeby nikt nie utworzył nowych wpisów, gdyż błędnie zapiszą się w tabelach.

    Podaję ustawienia w ramach wyjaśnienia niektórych pytań.

    System kodowania znaków dla MySQL: UTF-8 Unicode (utf8)
    System kodowania znaków dla MySQL: UTF-8 Unicode (utf8)
    Ustawienia języków w skrypcie dla English i Polski: HTML Character Set - UTF-8

    Gdzie mogłem popełnić błąd??


  8. #8
    Awatar Max
    Max
    Max jest nieaktywny There's something in the Air ...
    Dołączył
    sty 2008
    Posty
    4 775
    Przydatne posty
    252
    Wpisów
    13

    Domyślnie

    Skopiuj z bazy danych, z tabeli 'post' (lub prefix_post jeśli takowy istnieje) fragment gdzie zakodowane są polskie znaki...Im więcej tym lepiej.

    Pozdr.
    MK


  9. #9
    Awatar Trescom
    Trescom jest nieaktywny Początkujący
    Dołączył
    wrz 2008
    Posty
    11

    Domyślnie

    Kod:
    Mam nadzieję, że nie będzie tu chołoty
    
    I stało się co miało się stać...
    
    Trzeba było odrazu zacząć od zrzutu. Wyłacz zaporę...
    Proszę bardzo. Tak wyglądają przykładowe teksty skopiowane bezpośrednio z tabeli "post".


Podobne wątki

  1. BBCode [ZS]
    By Pawlok in forum Pytania i problemy
    Odpowiedzi: 0
    Ostatni post / autor: 13.11.2010, 12:59
  2. Własny BBCode - problem
    By S.H.A.D.O.W. in forum Style
    Odpowiedzi: 0
    Ostatni post / autor: 17.10.2009, 01:02
  3. vbseo - problem z bbcode`m
    By Juniorsky in forum vBSEO
    Odpowiedzi: 1
    Ostatni post / autor: 07.05.2009, 13:46
  4. problem z nowym bbcode podczas przelaczania do trybu wizualnego
    By bartek24m in forum Pytania i problemy
    Odpowiedzi: 1
    Ostatni post / autor: 18.03.2009, 12:09
  5. problem z bbcode
    By Twee in forum Pytania i problemy
    Odpowiedzi: 5
    Ostatni post / autor: 21.07.2008, 12:22
Chmurka.pl

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67