• Rejestracja
vBHELP.pl - polskie wsparcie vBulletin
  1. #1
    Mind jest nieaktywny Stały bywalec
    Dołączył
    paź 2008
    Posty
    377
    Przydatne posty
    3

    Domyślnie Problem z CREATE TABLE post

    Witam, mam problem z utworzeniem tabeli, podczas instalacji pojawia sie komunikat:

    Kod:
    Database error in vBulletin :
    
    Invalid SQL:
    
    CREATE TABLE post (
    	postid INT UNSIGNED NOT NULL AUTO_INCREMENT,
    	threadid INT UNSIGNED NOT NULL DEFAULT '0',
    	parentid INT UNSIGNED NOT NULL DEFAULT '0',
    	username VARCHAR(100) NOT NULL DEFAULT '',
    	userid INT UNSIGNED NOT NULL DEFAULT '0',
    	title VARCHAR(250) NOT NULL DEFAULT '',
    	dateline INT UNSIGNED NOT NULL DEFAULT '0',
    	pagetext MEDIUMTEXT,
    	allowsmilie SMALLINT NOT NULL DEFAULT '0',
    	showsignature SMALLINT NOT NULL DEFAULT '0',
    	ipaddress CHAR(15) NOT NULL DEFAULT '',
    	iconid SMALLINT UNSIGNED NOT NULL DEFAULT '0',
    	visible SMALLINT NOT NULL DEFAULT '0',
    	attach SMALLINT UNSIGNED NOT NULL DEFAULT '0',
    	infraction SMALLINT UNSIGNED NOT NULL DEFAULT '0',
    	reportthreadid INT UNSIGNED NOT NULL DEFAULT '0',
    	PRIMARY KEY (postid),
    	KEY userid (userid),
    	KEY threadid (threadid, userid),
    	FULLTEXT KEY title (title, pagetext)
    ) ENGINE=MyISAM;
    
    MySQL Error   : Column 'title' cannot be part of FULLTEXT index
    Error Number  : 1283
    .
    .
    .
    .
    Nie wiem gdzie tkwi błąd, proszę o podpowiedź, pozdrawiam



  2. #2
    Awatar Max
    Max
    Max jest nieaktywny There's something in the Air ...
    Dołączył
    sty 2008
    Posty
    4 775
    Przydatne posty
    252
    Wpisów
    13

    Domyślnie

    W jakim celu chcesz utworzyć tabelę 'post', skoro istnieje ona po instalacji?


  3. #3
    Mind jest nieaktywny Stały bywalec
    Dołączył
    paź 2008
    Posty
    377
    Przydatne posty
    3

    Domyślnie

    Cytat Zamieszczone przez Max Kwiatkowski Zobacz posta
    W jakim celu chcesz utworzyć tabelę 'post', skoro istnieje ona po instalacji?
    Właśnie jest problem podczas instalacji cyt. moją wypowiedź "Witam, mam problem z utworzeniem tabeli, podczas instalacji pojawia sie komunikat: Może źle sformułowałem wypowiedź, powinno być podczas instalacji pojawia się błąd z utworzeniem tabeli. Nie wiem gdzie szukać błędu.


  4. #4
    Awatar Max
    Max
    Max jest nieaktywny There's something in the Air ...
    Dołączył
    sty 2008
    Posty
    4 775
    Przydatne posty
    252
    Wpisów
    13

    Domyślnie

    Sorry, nie doczytałem. Jakie kodowanie jest ustawione dla bazy?


  5. #5
    Mind jest nieaktywny Stały bywalec
    Dołączył
    paź 2008
    Posty
    377
    Przydatne posty
    3

    Domyślnie

    UTF-8 Unicode (utf8)


  6. #6
    Awatar Max
    Max
    Max jest nieaktywny There's something in the Air ...
    Dołączył
    sty 2008
    Posty
    4 775
    Przydatne posty
    252
    Wpisów
    13

    Domyślnie

    Spróbuj odpalić takie zapytanie:
    Kod:
    ALTER TABLE post CONVERT TO CHARACTER SET utf8;


  7. #7
    Mind jest nieaktywny Stały bywalec
    Dołączył
    paź 2008
    Posty
    377
    Przydatne posty
    3

    Domyślnie

    Kod:
    zapytanie SQL: 
    
    ALTER TABLE post CONVERT TO CHARACTER SET utf8;
    
    
    MySQL zwrócił komunikat:  
    #1146 - Table 'XXXXXXXX.post' doesn't exist


  8. #8
    Awatar Max
    Max
    Max jest nieaktywny There's something in the Air ...
    Dołączył
    sty 2008
    Posty
    4 775
    Przydatne posty
    252
    Wpisów
    13

    Domyślnie

    Typ bazy danych to MyISAM czy InnoDB?


  9. #9
    Mind jest nieaktywny Stały bywalec
    Dołączył
    paź 2008
    Posty
    377
    Przydatne posty
    3

    Domyślnie

    ENGINE=MyISAM

    Wiem gdzie leży już prawdopodobnie bląd, TUTAJ.

    Kod:
    z racji wydajnościowych użytkownicy nie moga tworzyc fulltextowych indexów
    U mnie też pojawia się ten sam komunikat i błąd co widac w pierwszym poście, czyli:

    Kod:
    MySQL Error   : Column 'title' cannot be part of FULLTEXT index
    Error Number  : 1283
    Nie pozostaje mi nic innego chyba, jak kontakt z adminem tego hostingu, bo tam mam konto, tym bardziej, ze robiłem test na innym serwerze i instalacja przebiegła bez problemu.


Podobne wątki

  1. Problem z kolumną Last Post By.
    By vDk in forum Instalacja i upgrade
    Odpowiedzi: 0
    Ostatni post / autor: 22.12.2009, 18:40
  2. PHP GET POST - Problem
    By marek.wolan in forum PHP / MySQL / AJAX
    Odpowiedzi: 3
    Ostatni post / autor: 17.12.2009, 00:34
  3. bbcode table
    By Broker in forum Pytania i problemy
    Odpowiedzi: 5
    Ostatni post / autor: 21.06.2009, 23:08
  4. Post Thank You - Hacl (Problem)
    By fidgethouse in forum Pytania i problemy
    Odpowiedzi: 5
    Ostatni post / autor: 01.05.2009, 09:31
  5. Edycja roznych obszarow table header
    By uzin2 in forum Pytania i problemy
    Odpowiedzi: 3
    Ostatni post / autor: 10.08.2008, 12:25
Chmurka.pl

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67