• Rejestracja
vBHELP.pl - polskie wsparcie vBulletin
  • Tagi:
  1. #1
    Awatar brattanek
    brattanek jest nieaktywny Stały bywalec
    Dołączył
    lis 2008
    Posty
    410
    Przydatne posty
    4

    Domyślnie sitemapa generuje mape ktorej nie ma na serwerze

    Dzisiaj sprawdzalem jak dziala sitemapa od vbseo i mam pewien problem jak odpalam generacje sitemapy to powinna ona sie znajdowac pod linkiem http://xboxforum.pl/sitemap_index.xml.gz na serwerze nie ma takiego pliku (nie tworzy sie) wyswietlany jest komunikat 404 - Not Found. Gdzie ten plik sie zapisuje?



  2. #2
    Awatar g0rn
    g0rn jest nieaktywny Stały bywalec
    Dołączył
    maj 2009
    Posty
    188
    Przydatne posty
    5

    Domyślnie

    Cytat Zamieszczone przez brattanek Zobacz posta
    Dzisiaj sprawdzalem jak dziala sitemapa od vbseo i mam pewien problem jak odpalam generacje sitemapy to powinna ona sie znajdowac pod linkiem http://xboxforum.pl/sitemap_index.xml.gz na serwerze nie ma takiego pliku (nie tworzy sie) wyswietlany jest komunikat 404 - Not Found. Gdzie ten plik sie zapisuje?
    A jak wygląda twój .htacess


  3. #3
    Awatar brattanek
    brattanek jest nieaktywny Stały bywalec
    Dołączył
    lis 2008
    Posty
    410
    Przydatne posty
    4

    Domyślnie

    uzywam lighttpd:
    Kod:
    $HTTP["host"] == "xboxforum.pl" {
    server.document-root = "/www/"
    url.rewrite-once = (
    "^/((urllist|sitemap).*\.(xml|txt)(\.gz)?)" => "/vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1",
    "^(/forums/(admincp|modcp|clientscript|cpstyles|images|customavatars|api\.php)/.*)$" => "$1",
    "^(/forums/vbseo/resources/(css|images|scripts)/.*)$" => "$1",
    "^(/favicon\.ico|/robots\.txt|.*clear\.gif)$" => "$1",
    "^/forums/(.+)\?(.*)$" => "/forums/vbseo.php?$2",
    "^/forums/(.+)$" => "/vbseo.php"
    )
    }


  4. #4
    Awatar WoG
    WoG
    WoG jest nieaktywny vB Specialist
    Dołączył
    lut 2008
    Posty
    2 812
    Przydatne posty
    297
    Wpisów
    1

    Domyślnie

    Nigdy nie jest tworzony plik sitemap_index.xml.gz, w głównym katalogu forum.
    Ten link ma być dostępny przez rewrite i ma prowadzić do pliku: /vbseo_sitemap/vbseo_getsitemap.php

    Wszystkie sitemapy są w katalogu /vbseo_sitemap/data (ten katalog musi mieć uprawnienia do zapisu).
    Masz tam coś w katalogu z rozszerzeniem .xml.gz?

    Z tego co widzę, sitemap działa prawidłowo. Przykład: http://xboxforum.pl/vbseo_sitemap/vb...p_index.xml.gz

    Może warto przeinstalować od nowa vBSEO Sitemap Generator?

    Dlaczego raz w regułach lighttpd, masz ścieżkę do forum poprzez /forums/?
    Z tego co widzę, forum jest w głównym katalogu, a nie w /forums.
    Z poważaniem,
    WoG

    Ty też możesz pomóc spolszczać vBulletin 5: GitHub.com
    "Rozczarowanie spowodowane niską jakością pamięta się długo po przeminięciu radości spowodowanej niską ceną"


Chmurka.pl

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67