• Rejestracja
vBHELP.pl - polskie wsparcie vBulletin
  • Tagi:
  1. #1
    prac jest nieaktywny Użytkownik
    Dołączył
    lip 2010
    Posty
    48
    Przydatne posty
    3

    Domyślnie Powrot z vb 4.18 do vb 4.1.7

    Czy istnieje możliwość powrotu z vb 4.1.8 do vb 4.1.7 bo po zmianie nie mogę opanować forum. Samoczynnie rozjeżdża mi się styl, edytor stracił wszystkie ikony. Ogólnie jestem rozczarowany. Ukrywanie linków przed gośćmi raz działa raz nie jak ukryje stare posty to są widoczne nowe. Szkoda że już nie ma powrotu do 3.8 bo chyba był najbardziej stabilny.



  2. #2
    MaTusz jest nieaktywny Użytkownik
    Dołączył
    wrz 2009
    Posty
    51
    Przydatne posty
    6

    Domyślnie

    jak masz baze z 4.1.7 to tak a jak nie masz to i tak można, podmieniasz pliki na ftp, robisz upgrade do 4.1.7 i później poprawiasz błędy na forum i z bazie i tyle.


  3. #3
    Awatar WoG
    WoG
    WoG jest nieaktywny vB Specialist
    Dołączył
    lut 2008
    Posty
    2 812
    Przydatne posty
    297
    Wpisów
    1

    Domyślnie

    Cytat Zamieszczone przez MaTusz Zobacz posta
    robisz upgrade do 4.1.7
    Po pierwsze ten zabieg nazywa się downgrade.
    Po drugie nie wykona się tego z poziomu instalatora vB.

    Jeżeli wykonałeś kopię przed aktualizacją - przywróć ją.
    Jeżeli nie - droga do zrobienia downgrade jest dość długa.
    Z poważaniem,
    WoG

    Ty też możesz pomóc spolszczać vBulletin 5: GitHub.com
    "Rozczarowanie spowodowane niską jakością pamięta się długo po przeminięciu radości spowodowanej niską ceną"


  4. #4
    prac jest nieaktywny Użytkownik
    Dołączył
    lip 2010
    Posty
    48
    Przydatne posty
    3

    Domyślnie

    Nie jest to pociecha, mam jednak nadzieję że wszelkie błędy znikną i ostatecznie będziemy chwalili dobrą wersje VB4xx.
    Kopie mam ale utracę posty napisane od tego czasu i userów którzy się zarejestrowali. Mam nadzieję że z pomocą innych uda się rozwiązać problemy.


  5. #5
    Marcin_J_ jest nieaktywny Stały bywalec
    Dołączył
    lis 2010
    Posty
    110
    Przydatne posty
    9

    Domyślnie

    prac , a nie lepiej doprowadzić do ładu obecną wersję po aktualizacji ?
    ostatnio robiłem aktualke z 4.0.8 do 4.1.8... było sporo przeszkód ale wszystko dało się poprawić


  6. #6
    MaTusz jest nieaktywny Użytkownik
    Dołączył
    wrz 2009
    Posty
    51
    Przydatne posty
    6

    Domyślnie

    Cytat Zamieszczone przez Wojtek Zobacz posta
    Po pierwsze ten zabieg nazywa się downgrade.
    Po drugie nie wykona się tego z poziomu instalatora vB.

    Jeżeli wykonałeś kopię przed aktualizacją - przywróć ją.
    Jeżeli nie - droga do zrobienia downgrade jest dość długa.
    zwykla pomylka tez mi cos. nie mow ze sie nie wykona z poziomu instalatora skoro w taki sposob robilem downgrade, widze ze cos slabo u ciebie z praktyka, nie tylko na teorii sie opierajcie tam w supporcie

    i droga do downgrade nie jest dluga, mi zajelo lacznie z podmianą plikow jakieś 30 minut nie wliczajac poprawek


  7. #7
    Seba jest nieaktywny Advanced Member
    Dołączył
    lut 2009
    Posty
    1 059
    Przydatne posty
    44

    Domyślnie

    zwykla pomylka tez mi cos. nie mow ze sie nie wykona z poziomu instalatora skoro w taki sposob robilem downgrade, widze ze cos slabo u ciebie z praktyka, nie tylko na teorii sie opierajcie tam w supporcie
    True.

    Przykładowo downgrade z 4.1.5 do 4.1.3 (aby pozbyć się ckeditora) przechodzi bezproblemowo.
    Profesjonalne modyfikacje vBulletin oraz style - gg 1981480 badz PW


  8. #8
    prac jest nieaktywny Użytkownik
    Dołączył
    lip 2010
    Posty
    48
    Przydatne posty
    3

    Domyślnie

    Cały problem jest w ukrywaniu linków przed gośćmi, wypróbowałem już chyba wszystkie możliwości. Stare linki ukrywa a w nowych postach nie, jak edytuję posta to zmienia. Ogólnie nie do opanowania.


  9. #9
    Awatar WoG
    WoG
    WoG jest nieaktywny vB Specialist
    Dołączył
    lut 2008
    Posty
    2 812
    Przydatne posty
    297
    Wpisów
    1

    Domyślnie

    Nie powiem, bo sposób, którym się posługujecie jest dość cwany, ale nadal będę się trzymał swojej "supportowej" wersji, że nie jest to w pełni wykonalne (w niektórych przypadkach).

    Wasz sposób polega na "oszukaniu" skryptu do upgrade vBulletin.
    Umieszczając pliki od vB np. 4.1.7 na wersję 4.1.8 instalator widzi jako 4.1.7 i dąży do aktualizacji do tej wersji, bo ma ją jako ostatnią dostępną.

    W Waszym przypadku wszystko przeszło pomyślnie, bo zmiany w bazie danych były minimalne.
    Wykonanie downgrade tą metodą nie likwiduje zmian w bazie danych wprowadzonych przez nowsze wersje.

    Może się zdarzyć, że pewnego dnia aktualizacja zmieni w bazie nazwę kolumny np. z "postid" na "id" (dość mało wiarygodny przykład, ale podałem dla uproszczenia). W tym przypadku opisana wyżej metoda się nie sprawdzi, bo stare vB będzie szukało "postid", a "aktualizacja do starszej wersji" nie weźmie powyższych zmian pod uwagę. Wtedy zostajemy z błędem.

    Oficjalny support vBulletin odradza tą metodę, ale cenie sobię u Was spryt vBHELPowicze
    Z poważaniem,
    WoG

    Ty też możesz pomóc spolszczać vBulletin 5: GitHub.com
    "Rozczarowanie spowodowane niską jakością pamięta się długo po przeminięciu radości spowodowanej niską ceną"


Chmurka.pl

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67