• Rejestracja
vBHELP.pl - polskie wsparcie vBulletin
  1. #1
    soprano jest nieaktywny Użytkownik
    Dołączył
    sie 2008
    Posty
    31

    Domyślnie Parę pytań po konwersji

    Przede wszystkim chciałbym zadać pytanie o to, jak wyczyścić baze PW, gdyz nie znalazłem o tym informacji, a jedynie wspomniał o tym Max w jednym ze swoich postów. Chciałbym rownież zapytać o to, dlaczego po zalogowaniu nadal widzę przycisk "zarejestruj się".

    Pewnie jeszcze znajdzie się parę pytań, dlatego będę je umieszczał tutaj, bo nie ma sensu zaśmiecać forum. Tak mi sie przynajmniej wydaje



  2. #2
    Awatar Max
    Max
    Max jest nieaktywny There's something in the Air ...
    Dołączył
    sty 2008
    Posty
    4 775
    Przydatne posty
    252
    Wpisów
    13

    Domyślnie

    Ad.1.
    Wyczyść tabelę 'pm'.

    Ad.2.
    Na każdym stylu?


  3. #3
    soprano jest nieaktywny Użytkownik
    Dołączył
    sie 2008
    Posty
    31

    Domyślnie

    ad. 1 - Jak mam wyczyścić tabele PM?
    ad. 2 - Tak na wszystkich stylach (forum po konwersji z MyBB)

    PS: Sorki, że zadaję takie głupie pytania, ale slabo znam vBulletin.


  4. #4
    Awatar Max
    Max
    Max jest nieaktywny There's something in the Air ...
    Dołączył
    sty 2008
    Posty
    4 775
    Przydatne posty
    252
    Wpisów
    13

    Domyślnie

    Ad.1. Zaloguj się do phpMyAdmin, odnajdź tabelę 'pm' i kliknij buttonik 'Wyczyść' z prawej strony nazwy tabeli.
    Ad.2. Widzisz po prawej stronie komunikat "Witaj soprano..." i jednocześnie link do rejestracji po lewej?


  5. #5
    soprano jest nieaktywny Użytkownik
    Dołączył
    sie 2008
    Posty
    31

    Domyślnie

    Ad.1 Dzieki, zaraz będę sprawdzał czy to zadziała
    Ad.2 Tak

    Rejestrację widzę, jak jestem zalogowany oraz wylogowany. W przypadku, gdy jestem wylogowany, to widzę pole logowania i rejestrację (tak jak ma być).

    Podaje link do forum:
    Forum savoir-vivre


  6. #6
    soprano jest nieaktywny Użytkownik
    Dołączył
    sie 2008
    Posty
    31

    Domyślnie

    AD. 1 Zrobiłem tak jak pisałeś i nadal mam ten problem:
    Skrzynka odbiorcza zawiera 0 wiadomości.
    Masz 71 zapisanych wiadomości, z 50 dozwolonych. (Wyczyść Folder)
    - czyszczę i nic


  7. #7
    Awatar Max
    Max
    Max jest nieaktywny There's something in the Air ...
    Dołączył
    sty 2008
    Posty
    4 775
    Przydatne posty
    252
    Wpisów
    13

    Domyślnie

    Miałem na myśli wyczyszczenie tabeli w bazie danych. Tabela nosi nazwę 'pm' (lub prefix_pm jeśli ustaliłeś).
    Niemożliwe jest, aby po wyczyszczeniu wiadomości z bazy danych nadal znajdowały się one w skrzynce.


  8. #8
    soprano jest nieaktywny Użytkownik
    Dołączył
    sie 2008
    Posty
    31

    Domyślnie

    Rozwiązanie problemu z widocznym przyciskiem "rejestracja" po zalogowaniu
    Register in navbar stays after login... how to fix this? - vBulletin Community Forum

    Co do PM, to wiem, że ich nie może być i ich nie ma. Licznik nadal pokazuje 100%, więc pewnie tu tkwi problem. Oczywiście po konwersji "przebudowałem" wszystkie liczniki z forum z panelu admina.

    Kolejne pytanie:
    Jak w TfSEO ustawić polskie zamienniki dla znakół ąćźżółń itd?
    Zauważyłem, że trzeba edytować pliki tego dodatku, ale nie wiem jak to zrobić. Wpisuje polskie znaki np. do pliku tfseo_wide.php, czy jakos tak, ale i tak ich nie zamienia. Co mogę robić źle?


  9. #9
    soprano jest nieaktywny Użytkownik
    Dołączył
    sie 2008
    Posty
    31

    Domyślnie

    Zacząłem kombinowac z tymi polskimi znakami

    Mam taki oto przykładowty plik (chyba język włoski), który jest kodowany w iso-8859-1
    Kod:
    <?php
    
    function remove_accents($string){
    
        return strtr($string,
    
                    "€&ěéčň@ŕů",
    
                    "eeieeoaau");
    
    }
    
    ?>
    Przekonwertowałem sobie polskie znaki do UTF a następnie z UTF do iso-8859-1, bo akurat gżegżółka źle u mnie działa i trzeba było poszukac czegoś innego.

    Dało mi to wielkie nic. Polskich znaków nie zamienia, a po prostu je ucina. Przedtem zamiast polskiego odpowiednika była pauza, a teraz nie ma po prostu znaku. Przyczyna może być w tym, że źle przekonwertowało mi te znaki, albo że nie w tym tkwi problem. Mimo wszystko TfSEO obsługuje więcej języków (takich własnie plików, jak przykład u góry), a więc z językiem polskim też się tak powinno dać zrobić.

    Czy ktoś ma jakies pomysły? Czy ktoś używa TfSEO i rozwiązał ten problem?
    [QUOTE=Administrator forum savoir-vivre.pl][B]SAVOIR-VIVRE.PL[/B] :: Forum traktuje o zasadach dobrych manier.[/QUOTE]


Podobne wątki

  1. Błędy po konwersji
    By Ojciec Dyretor in forum Konwersje
    Odpowiedzi: 9
    Ostatni post / autor: 01.12.2010, 02:05
  2. Grupy po konwersji
    By powerman3 in forum Konwersje
    Odpowiedzi: 1
    Ostatni post / autor: 18.10.2010, 22:34
  3. Problemy po konwersji
    By swist in forum Pytania i problemy
    Odpowiedzi: 2
    Ostatni post / autor: 12.04.2010, 02:41
  4. Parę pytań - podstawowe rzeczy :)
    By MaXFireN in forum Pytania i problemy
    Odpowiedzi: 1
    Ostatni post / autor: 24.12.2009, 14:23
  5. Parę pytań
    By cola in forum Przed zakupem - pytania początkujących
    Odpowiedzi: 11
    Ostatni post / autor: 17.12.2009, 00:36
Chmurka.pl

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67