• Rejestracja
vBHELP.pl - polskie wsparcie vBulletin
  1. #1
    Polm jest nieaktywny Początkujący
    Dołączył
    lut 2010
    Przegląda
    Gogolewo, Slupsk, Poland, Poland
    Posty
    7

    Domyślnie [?][SMF] Zamiast polskich znaków.

    Witam. Nie znalazłem na tym forum tematu który by mi pomógł, dlatego zakładam nowy. Ok, przejdźmy do meritum.

    Mam bazę danych z SMF 2.0 RC2 na kodowaniu utf8_general_ci i wszystko pięknie, polskie znaki są. Mam też świeżo zainstalowaną bazę vBulletin 4.0.1, przy pisaniu nowego postu również są ładne polskie znaki. W głównym configu vB linijkę odpowiadającą za kodowanie mam zakomentową, w configu od impex'a dwie linijki odpowiedzialne za kodowanie bazy źródłowej i docelowej są puste. Dodam jeszcze, że obie bazy są na tym samym serwerze mysql. Po konwersji kodowanie nie zmienia się, jest nadal utf8_general_ci, ale zamiast polskich znaków są już "?"

    Próbowałem już wszystkiego, konwersja ze spolszczeniem vb, bez, bez spolszczenia SMF, z nim. I nadal jest to samo.

    Jakieś rady, panowie(i panie)?



  2. #2
    Awatar Max
    Max
    Max jest nieaktywny There's something in the Air ...
    Dołączył
    sty 2008
    Posty
    4 775
    Przydatne posty
    252
    Wpisów
    13

    Domyślnie

    Zdejmij komentarz z linii traktującej o kodowaniu w pliku includes/config.php .


  3. #3
    Polm jest nieaktywny Początkujący
    Dołączył
    lut 2010
    Przegląda
    Gogolewo, Slupsk, Poland, Poland
    Posty
    7

    Domyślnie

    Było zdjęte.
    Dla potomności napiszę w czym tkwi problem. Otóż sprawa jest bardzo prosta. Kodowanie spolszczenia gryzło się z kodowaniem bazy danych. Grzegrzółka nie dawała sobie rady, dlatego polecam kED2, który ma dużo ciekawych opcji swoją drogą, oczywiście jeśli baza ma utf8 to tak samo przekonwertujemy spolszczenie i będzie ładnie śmigać wszystko.


  4. #4
    Awatar error
    error jest nieaktywny Stały bywalec
    Dołączył
    lip 2008
    Posty
    197
    Przydatne posty
    2

    Domyślnie

    Mógłbyś napisać jak przekonwertowales spolszczenie programem kED2


  5. #5
    Polm jest nieaktywny Początkujący
    Dołączył
    lut 2010
    Przegląda
    Gogolewo, Slupsk, Poland, Poland
    Posty
    7

    Domyślnie

    Odpalasz kED2 wczytujesz plik xml, dajesz F4 i prawdopodobnie ta konfiguracja będzie dobrze ustawiona, dajesz "Zmień" i powinno być


Podobne wątki

  1. Odpowiedzi: 5
    Ostatni post / autor: 17.11.2009, 21:09
  2. Odpowiedzi: 5
    Ostatni post / autor: 24.09.2009, 23:16
  3. [Zlecę] Zrobienie Polskich Znaków Zamiast Znaków Zapytania
    By ziomix28 in forum Giełda
    Odpowiedzi: 9
    Ostatni post / autor: 16.06.2009, 20:47
  4. Odpowiedzi: 22
    Ostatni post / autor: 08.12.2008, 20:42
  5. Pytajniki zamiast polskich znaków :(
    By Tomek58 in forum Pytania i problemy
    Odpowiedzi: 10
    Ostatni post / autor: 25.06.2008, 17:07
Chmurka.pl

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67